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About us

Cornel - Phd. Lecteur at the University of Bucharest, Faculty of
Geography, Department of Geomorphology, Pedology,
Geomatics. Cornel is specialized on raster modeling of relief,
analysis of watersheds and 3D modeling of geographic reality. It
promotes the use of open source solutions in universities.
From 2010 Cornel is a board member of geo-spatial.org.

Ionu ț - Phd. Lecteur at University of Bucharest, Faculty of
Geography, and has over 13 years of experience in geospatial
technology, advocate for using free and open source solutions
in the public sector. Is member of the geo-spatial.org board and
currently collaborates with the European Union External Action
Service in EUMM Georgia.
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Workshop schedule

1. Creating DEM

2. Viewing DEM

3. Setting DEM for modeling

4. Basis parameter of DEM



5. DEM and hydrological elements

6. Flood simulation

7. Query DEM - profiles

Workshop schedule



1. Creating DEM



Realizarea MNAT

1. Importul curbelor de nivel (linie – ESRI Shapefile): 
File -> Import vector data -> Common import formats [v.in.ogr]

2. Select type of flile: ESRI Shapefile
3. Select location: home/freegis/data/GRASS/curbe_nivel/curbe_nivel.shp   



Realizarea MNAT

Definim proprietatile mediului de lucru:
Settings -> Region -> Set region



Realizarea MNAT

Utilizam functia g.region:
�Selectam tab-ul: Rezolution.
�Setam rezoluţia utilizand campul Grid
resolution 2D introducerea valoarea 10
(unitatea de masura fiind metru).
�Selectam tab-ul: Existing
�introduem în Set region to match this
vector map numele hărţii vectoriale care
trebuie să fie convertite într-un raster, în
contururi cazul nostru. Odată ce aţi
terminat faceţi clic pe Run. Acum,
regiunea curentă acoperă întreaga hartă
cu contururi rezoluţie de 10 metri.



3. Conversia vector in raster: 
data/GRASS/curbe_nivel/curbe_nivel.shp     

Utilizam functia v.to.rast: File -> Map type conversions -> Vector to raster

�Selectam tab-ul: Required.

�Introducem datele vectoriale
(curbe_nivel)

Name of imput vector map

(contours)
Name fror output raster map

(attr)
Name of imput vector map

Realizarea MNAT



� Selectam tab-ul: Attributes
Name of ccolumn for ´attr´ parameter
coloana dupa care se face conversia - altitudinea (ID)

Realizarea MNAT



Rezultatul obtinut: harta a curbelor rasterizata

Realizarea MNAT



4. Realizarea MNA - utilizam functia: r.surf.contour
Raster -> Interpolate surfaces-> Raster contours 

Functia r.surf.contour creează o hartă a altitudinilor dintr-o hartă a curbelor rasterizata.
Algoritmul de interpolare: interpolare liniara (linearly interpolates)

Realizarea MNAT



Rezultatul obtinut: Modelul Numeric Altimetric

Realizarea MNAT



Rezultatul obtinut: Modelul Numeric Altimetric + curbele de nivel

Realizarea MNAT



2. Vizualizarea MNAT



Vizualizarea MNAT

1. Selectam tipul de fisier: Arc/Info ASCII Grid
2. Selectam locatia: home/freegis/data/GRASS/model/model5m.asc
3. Bifam: Override projection si Add Imported layers into layer tree
3. Apasam butonul: Import 

In fereastra GIS Layer Manager, la optiunea
Command output, va apare urmatorul mesaj:



Pentru vizualizarea stratului: Click dreapta de mouse si din meniul contextual alegem:

Zoom to selected map(s)

Vizualizarea MNAT



Pentru selectarea zonei: Click dreapta de mouse si din meniul contextual alegem

Set computational region
from selected map(s)

Vizualizarea MNAT



Raster > Terrain analysis > Shaded relief

Vizualizarea MNAT



La Imput elevation map alegem: model5m@PERMANENT si apasam Run apoi Close

Vizualizarea MNAT



In fereastra GRASS GIS Layer Manager, schimbam ordinea de afisare a stratelor astfel:
1.model5m@PERMANENT  

2.model5m.shade@PERMANENT

Click dreapta pe 
model5m@PERMANENT

si alegem
Change opacity level

Vizualizarea MNAT



In fereastra Set opacity, selectam opacitatea la 50 unitati

Vizualizarea MNAT



Rezultatul final

Vizualizarea MNAT



Vizualizare 3D

In fereastra GRASS GIS Layer Manager efectuam: File > NVIZ

Vizualizarea MNAT



Alegem la Name of raster(s) for Elevations: model5m@PERMANENT, iar la Name of 
raster map(s) for Color: model@PERMANENT si rulam comanda.

Vizualizare 3D

Vizualizarea MNAT



Rezultatul final:
Vizualizare 3D

Vizualizarea MNAT



Schimbarea proprietatilor de vizualizare

Se face cu optiunea Lighting Panel : Apparence > Lighting

Light source position: directia de iluminare

Light color: modifica nuantele de culoare

Light intensity: modifica intensitatea luminii

Vizualizare 3D

Vizualizarea MNAT



Schimbarea proprietatilor de vizualizare

Vizualizare 3D

Vizualizarea MNAT



3. Pregătirea MNAT pentru 
modelare raster



Calitatea MNA determin ă calitatea analizei geomorfologice. 
Chiar şi cei mai sofistica ţi algoritmi de procesare sunt în imposibilitate de a 

rectifica erorile din MNA de intrare. Calitatea par ametrilor suprafe ţei pentru 

aplica ţiile geomorfologicedepind de mai mul ţi factori 
(Accuracy of local topographic variables derived fr om digitalelevation models, Igor Florinsky, 1998) :

�rugozitatea suprafe ţei terenului;

�densitatea de prelevare a probelor; 

�algoritmul de ob ţinere a MNA;

�rezolu ţia vertical ă;

�tipul de analiz ă geomorfologic ă.

Pregatirea MNAT pentru modelare



Elementele MNA

Pregatirea MNAT pentru modelare



Chiar şi cei mai exac ţi algoritmi vor avea ca rezultat în ie şiri eonate 
în cazul în care MNA de intrare este de proast ă calitate sau 

necorespunz ătoare pentru aplicatiile alese.

Înainte de realizarea diversilor parametrii ai tere nului 

Trebuie urmate diverse proceduri pentru a îmbun ătăţi calitatea MNA. 

Aceste proceduri sunt disponibile în multe pachete de programe sub numele 

de DEM processing sau DEM preparation.

In GRASS GIS - Fill NULL cells

Pregatirea MNAT pentru modelare



� eliminarea erorilor,
• o aproximare mai bun ă a suprafe ţei terenului,

• o aproximare mai bun ă a proceselor hidrologice / ecologice 
(cum ar fi debit, radia ţii etc).

În principiu, orice prelucrare de MNA are trei obie ctive principale:

Pregatirea MNAT pentru modelare



Identificarea erorilor:

In SE regiunii se afla un gol

Pregatirea MNAT pentru modelare



Umplerea ¨golurilor ¨

Golurile (sinks) sunt elementele care au fost 

introduse la generarea MNA.

Eliminarea golurilor este un pas de pre-procesare, determinat ă 

în principal de c ătre aplica ţiile hidrologice în care o re ţea 

hidrologic ă corect ă este cea care simuleaza fluxul de ap ă 

pe suprafa ţa solului 
(Tarboton, D. G., R. L. Bras and I. Rodriguez-Iturb e, (1991), "On the Extraction of Channel

Networks from Digital Elevation Data," Hydrologic P rocesses, 5(1): 81-100).

Golurile sunt completate progresiv (prin cre şterea cotei lor)

până la atingerea punctului cel mai mic scurgere este a tins

Nivelarea ¨vârfurilor ¨

Pregatirea MNAT pentru modelare



Umplerea ¨golurilor ¨

Nivelarea ¨vârfurilor ¨

Pregatirea MNAT pentru modelare



In fereastra de manipulare (Layer Manager) click dr eapta pe strat> 
Set computational region from selected map(s)

Definirea zonei de procesare

Pregatirea MNAT pentru modelare



Se face cu optiunea
Raster > Interpolate surface > Fill NULL cells

GRASS GIS > r.fillnulls

umple pixelii din zonele fără date 

Umplerea ¨golurilor ¨

Nivelarea ¨vârfurilor ¨

Pregatirea MNAT pentru modelare



4. Parametrii de baz ă ai MNAT



Raster > Terrain analysis

Parametrii de baz ă ai MNAT



Paramatrii de baza ai MNA 
pot fi deriva ţi direct dintr-un MNA f ără a cunoa şte zona reprezentat ă

Parametrii de baz ă ai MNAT



Importam zona de lucru : File > Import raster data > Common import formats

Parametrii de baz ă ai MNAT



Importam zona de lucru : File > Import raster data > Common import formats

Parametrii de baz ă ai MNAT



Importam zona de lucru : File > Import raster data > Common import formats

Parametrii de baz ă ai MNAT



Interogarea datelor raster – harti geomorfologice

Executam: Raster > Terrain analysis > Slope and Aspect

Parametrii de baz ă ai MNAT



Interogarea datelor raster – harti geomorfologice

Completam cerintele obligatorii: la name of 
elevation raster map alegem 
model5m@Tutorial, numele stratelor de 
iesire...

Parametrii de baz ă ai MNAT



Interogarea datelor raster – harti geomorfologice
... si parametrii de calcul: Settings

Rulam comanda...

Parametrii de baz ă ai MNAT



Interogarea datelor raster – harti geomorfologice
Rezultate

Expozitia versantilorPantele

Parametrii de baz ă ai MNAT



Paramatrii de baza ai MNA 
pot fi deriva ţi direct dintr-un MNA f ără a cunoa şte zona reprezentat ă

Parametrii de baz ă ai MNAT



Interogarea datelor raster – harti geomorfologice

Completam cerintele obligatorii: la name of 
elevation raster map alegem 
model5m@Tutorial, numele stratelor de 
iesire...

Parametrii de baz ă ai MNAT



Interogarea datelor raster – harti geomorfologice
... si parametrii de calcul: Settings

Rulam comanda...

Parametrii de baz ă ai MNAT



Interogarea datelor raster – harti geomorfologice
Rezultate

Curbura in profilCurbura in plan

Parametrii de baz ă ai MNAT



Paramatrii de baza ai MNA 
pot fi deriva ţi direct dintr-un MNA f ără a cunoa şte zona reprezentat ă

Parametrii de baz ă ai MNAT



Interogarea datelor raster – vizibilitatea 

Parametrii de baz ă ai MNAT

r.los generează o hartă raster, în care celulele 

care sunt vizibile dintr-o poziţie a observatorului 

sunt marcate cu unghiul vertical (în grade). 

Valoarea 0 (zero) este direct in jos, 

90 este  la orizontală şi 180 este deasupra observatorului. 

r.los - Line-of-sight



Interogarea datelor raster – vizibilitatea 

Parametrii de baz ă ai MNAT



Interogarea datelor raster – vizibilitatea

Parametrii de baz ă ai MNAT



Interogarea datelor raster – vizibilitatea

Parametrii de baz ă ai MNAT



Caracterizarea geomorfologica a MNAT

Parametrii de baz ă ai MNAT

Modulul r.param.scale extrage formele de relief de baza din MNAT

cum ar fi varfurile, interfluviile, trecatorile, vaile etc. 

Acest modul este bazat pe lucrarea lui Joo Wood 

(1996 - The geomorphological characterisation of digital elevation models. 

Ph.D. Thesis.Department of Geography, University of Leicester, 

Leicester, UK, 185 pp.).



Caracterizarea geomorfologica a MNAT

Parametrii de baz ă ai MNAT

Scriem in Command console : 
r.param.scale in=dem10wgs output=morphologie param=feature size=9



5. Parametrii MNAT şi 
elemente de hidrologie



Elemente de hidrologie

Raster > Hydrologic modeling



Elemente de hidrologie

Modelarea hidrologic ă este una dintre cele mai importante aplica ţii ale GRASS GIS.

1. Directia de scurgere (flow direction)

2. Acumularea scurgerii (flow accumulation)

3. Indicele de convergenta topografica 
(topographic convergence index)

4. Analiza bazinelor hidrografice

Elemente analizate



Elemente de hidrologie

1. Directia de scurgere (flow direction)

2. Acumularea scurgerii (flow accumulation)
Determină regiunea acoperita de apa din precipitatii, ninsoare, etc.
Sinonime: Contributing area, upslope area 

3. Indicele de convergenta topografica (topographic  convergence index)

Determină directia de curgere a apei pe un versant.

Logaritmul raportului dintre acumularea scurgerii şi panta locala 



Elemente de hidrologie

r.terraflow - Flow computation for massive grids (float version). 

Executam: Raster > Hydrologic modeling > Flow accumulation

r.terraflow are ca intrare un model date raster de elevatie (MNAT) 

şi calculează direcţia de curgere şi acumularea fluxului, 

precum şi zonele inundate, ¨gropile¨ din bazinel hidrografice şi 

TCI de (indicele de convergenţă topografica) .



Elemente de hidrologie

Executam: Raster > Hydrologic modeling > Flow accumulation



Elemente de hidrologie

r.terraflow



Elemente de hidrologie

Indicele de convergenta
topograficaAcumularea scurgeriiDirectia de scurgere



Elemente de hidrologie

4. Analiza bazinelor hidrografice

Stabilim rezolutia regiunii cu 
g.region
(stabilim valoarea 30 de metri, 
în  tab-ul Rezolution si
rulam comanda).



Elemente de hidrologie

4.1. Extragerea bazinelor hidrografice
r.watershed - Watershed basin analysis program



Elemente de hidrologie

4.1. Extragerea bazinelor hidrografice

n=1000 n=5000



Elemente de hidrologie

4.1. Extragerea bazinelor hidrografice



Elemente de hidrologie

4.1. Extragerea bazinelor hidrografice
Utilizand modulul r.colors (Raster -> Manage colors -> Color tables),



Elemente de hidrologie

4.2. Extragerea retelei hidrografice
Scriem in Command console : >r.mapcalc log_acumulare=log(abs(acumulare)+1)



Elemente de hidrologie

4.2. Extragerea retelei hidrografice
Scriem in Command console : r.mapcalc rau_raster=if(log_acumulare>6)



Elemente de hidrologie

4.2. Extragerea retelei hidrografice
În cele din urmă, pentru a crea o hartă vectorială a reţelei râului, utilizaţi r.thin din meniu, 
selectând Raster > Transform Features > Thin pentru a ¨subţia¨ pixelii strabatuti de rauri



Elemente de hidrologie

4.2. Extragerea retelei hidrografice
Convertim reteaua de rauri din format raster in format vectorial r.to.vect din meniu, 
selectând File > Map type > Conversions



Elemente de hidrologie

4.2. Extragerea retelei hidrografice

Schimbarea proprietatilor vectorilor d.vect

Click dreapta pe tema retea_rauri@Permanent
si alegem obtiunea Properties



Elemente de hidrologie

4.2. Extragerea retelei hidrografice
d.vect



Elemente de hidrologie

4.2. Extragerea retelei hidrografice

Reteaua hidrografica
+

Bazinele hidrografice



Elemente de hidrologie

4.2. Extragerea retelei hidrografice
Conversia bazinelor hidrografice din format raster in format vector

File > Map type conversions > Raster to vector map



Elemente de hidrologie

4.2. Extragerea retelei hidrografice
Conversia bazinelor hidrografice din format raster in format vector

File > Map type conversions > Raster to vector map



Elemente de hidrologie

4.2. Extragerea retelei hidrografice



6.  Intersectarea MNAT cu 
un plan orizontal



Manipularea datelor in GRASS

Interogarea datelor raster - Vizualizare 3D

Se utilizeaza optiunea Surface panel: Vizualize > Raster Surface

Intersectarea suprafetei cu un plan orizontal

Current: stratul aspura caruia se fac modificari

Surface attributes: modificarea atributelor suprafetei

Resolution: cresterea/scaderea rezolutiei

DRAW CURRENT: se aplica dupa fiecare modificare



Manipularea datelor in GRASS

Interogarea datelor raster - Vizualizare 3D

Introducem planul de sectionare: New > New Constant

Intersectarea suprafetei cu un plan orizontal

New Constant:Adauga proprietatea Z planului
Constant: se introduce valoarea Z

Dupa introducerea valorii, aceasta apare la optiunea:
Curr.value (in cazul nostru 175)



Manipularea datelor in GRASS

Interogarea datelor raster - Vizualizare 3D

Rezultatul final:

Intersectarea suprafetei cu un plan orizontal



Manipularea datelor in GRASS

Interogarea datelor raster - Vizualizare 3D

Schimbarea transparentei stratului creat: Surface attributes... > transparency

Intersectarea suprafetei cu un plan orizontal

New Constant:Adauga transparenta planului
Constant: se introduce valoarea transparentei

Dupa introducerea valorii, aceasta apare la optiunea:
Curr.value (in cazul nostru 165)



Manipularea datelor in GRASS

Interogarea datelor raster - Vizualizare 3D

Rezultatul final:

Intersectarea suprafetei cu un plan orizontal



7.  Interogarea MNAT 
- profile -



Manipularea datelor in GRASS

Interogarea datelor raster - profile

In fereastra de vizualizare alegem: Analyze > Profile surface map

Selectam datele



Manipularea datelor in GRASS

Interogarea datelor raster - profile
In Profile Analysis alegem: Draw transect in map display window profile

Trasam linia de profil



Manipularea datelor in GRASS

Interogarea datelor raster - profile

In fereastra Profile Analysis alegem: Draw/re-draw profile



V A    M U L T U M I M !

contact@corneltudose.ro
ionut@ovejanu.eu

http://www.geo -spatial.org 
http://www.freegis.ro

http://opengis.unibuc.ro


