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I NTRODUCERE
G R A S S   GIS



Ce este GRASS?

IARBA, IERBURI, [substantiv feminin] = Nume generic dat plantelor erbacee, anuale sau
perene, cu partile aeriene verzi, subtiri si mladioase, folosite pentru hrana animalelor.

GRASS = IARBA

GRASS GIS (Geographic Resources Analysis Support System),
un System Informational Geografic (GIS).
Acesta este disponibil sub GNU General Public License (GPL).

Este o parte din familia proiectelor OSGeo



De unde vine GRASS?

GRASS a fost iniţial dezvoltat la începutul anului 1980 de către US Army Construction
Engineering Research Laboratories (USA-CERL) si a fost distribuit ca un software public.

USA-CERL s-a implicat in dezvoltarea GRASS pana la versiunea 4.1 în 1992, au adăugat
cinci patch-uri diferite şi actualizări si a scris si componentele de bază ale GRASS 5.0 (1995)

Din 1997 , proiectul a fost realizat de Grupul de Cercetare GRASS de Universitatea
Baylor,Waco (Texas), S.U.A. care a lansat versiunea 4.2 şi, împreună cu alte organisme
de dezvoltare, GRASS s-a actualizat şi a fost detectată de către un grup de cercetatori de
la Universitatea Hanovra condus de Markus Neteler care a supervizat dezvoltarea
versiunii 5 si a urmatoarelor.

GRASS a implicat un număr mare de agenţii federale din SUA, universităţi şi companii
private: NASA, NOAA, USDA, National Park Service, SUA Census Bureau, USGS.

GRASS a fost în dezvoltare continuă din anul 1982 (a fost distribuit publicului în 1989, dar a
avut o răspândire mare odată cu apariţia Internetului în anul 90).



De unde vine GRASS?

In perioada 1998-2001, GRASS a fost găzduit la Universitatea din Hanovra, Germania.

In perioada 2001-2007, GRASS a fost găzduit la ITC-IRST, Trento, Italia.

GRASS este dezvoltat de o retea mondiala de dezvoltatori care continua sa lanseze în
mod regulat noi versiuni.

Din 2008 site-ul web principal, GRASS mailing list-uri ale dezvoltatorilor şi alte listele
suplimentare de discutii sunt gazduite la Fundatia OSGeo în SUA.

Codul sursa este menţinut într-un server SVN (Apache Subversion).
Proiectul GRASS este sprijinit de numeroase site-uri mirror.

Apache Subversion (SVN abreviat, după numele comenzii „svn”) management al
versiunilor de software şi un sistem de control si revizuire fondat şi sponsorizat în anul
2000 de către CollabNet Inc. Acesta menţine versiunile curente şi istorice de fişiere,
cum ar fi codul sursa, pagini web, şi documentaţie.



Promotorii GRASS

Markus Neteler - Germania

2008 – present: Associate Professor, Department of Marine, Earth and
Atmospheric Sciences (MEAS), North Carolina State University (NCSU), Raleigh

1987 Ph.D. in Geodesy and Cartography, College of Civil Engineering, Slovak
Technical University, Bratislava, Czechoslovakia

1981 M.S. (dipl. Ing) in Geodesy and Cartography, College of Civil Engineering,
SlovakTechnical University with the Highest Scholastic Honors, Bratislava,
Czechoslovakia

2005 – 2010 PHD Spatio-temporal reconstruction of satellite-based temperature 
maps and their application to the prediction of tick and mosquito disease vector 
distribution in Northern Italy - University of Hannover (Germany)

Oct. 1993 - March 1999, DIPLOM-GEOGRAPH (Degree in Physical Geography and 
Landscape Ecology) UNIVERSITY OF HANNOVER

Oct. 1990 - Oct. 1993 UNIVERSITY OF HANNOVER, B.Sc. in Electrical Engineering 
("Vordiplom")

Helena Mitashova - Slovacia



Bibliografie GRASS

Markus Neteler and Helena Mitasova, 2008,
Open Source GIS: A GRASS GIS Approach. Third Editio n.
Springer, New York

GRASS GIS 6.0 Tutorial , 2005 Version 1.2 -
GDF Hannover



De unde obtin GRASS?

Site oficial:
http://grass.osgeo.org/

Mirror:
http://grass.unibuc.ro/index.php



De unde obtin GRASS?

GRASS - USB

GRASS – CD/DVD



De unde obtin GRASS?

GRASS – FreeGIS Live  DVD

http://www.freegis.ro



Câte versiuni de GRASS sunt?

GRASS 6.4.0

GRASS 6.5



Câte versiuni de GRASS sunt?

GRASS 7



Ce face GRASS?

�Operare pe platforme LINUX, Windows, Mac OsX
�Interoperabilitate cu standardele raster si vector
�Analiza vector 2D/3D
�Analiza raster 2D/3D
�Procesarea imaginilor
�Vizualizarea hartilor in format 2D/3D



O P E R A R E
G R A S S   GIS



Pornire GRASS

1. Executam in terminal comanda: grass -wxpython
1'. Executam in terminal comanda: grass -tcltk
2. Accesam Applications>Education>GRASS GIS

wxGUI este noua interfata a GRASS GIS. 
Este succesoarea interfetei Tcl/Tk GUI din GRASS 6.



Stabilirea zonei de lucru

1. Accesam Location wizard pentru definirea unei noi zone de lucru
2. Stabilim directorul de lucru: /home/user/grassdata
3. Stabilim numele zonei de lucru: Workshop
4. Apasam butonul: Next>



Stabilirea zonei de lucru

1. Alegem Select coordinate system parameters from a list 
pentru definirea coordonetelor

2. Apasam butonul: Next>



Stabilirea zonei de lucru

1. Cautam proiectia Universal Transverse Mercator (UTM)si o selectam

2. Apasam butonul: Next>



Stabilirea zonei de lucru

1. Alegem zona 35 si Datum with associated ellipsoid 

2. Apasam butonul: Next>



Stabilirea zonei de lucru

1. Cautam elipsoidul wgs84 si il selectam

2. Apasam butonul: Next>



Stabilirea zonei de lucru

1. Se afiseaza datele zonei de lucru

2. Apasam butonul: Finish



Stabilirea zonei de lucru

1. Stabilim marginile si proprietatile zonei de lucru

2. Apasam butonul: Set region

3.Apasam butonul Start GRASS pentru a porni programul



Stabilirea zonei de lucru

Ferestrele de lucru

Fereastra de vizualizare

Fereastra de manipulare a stratelor



Fereastra de vizualizare

Display map: Afiseaza harta in spatiul de lucru
Re-render map: Redeseneaza harta 
Display erase: Sterge harta
Pointer: Selecteaza pointer-ul
Query raster/vector map(s): Interogheaza harta afisata
Pan: Muta stanga-dreapta, jos-sus harta in spatiul de lucru
Zoom in: Mareste harta
Zoom out: Miscoreaza harta
Return to previous zoom: Intoarcere la zoom-ul anterior
Zoom options: Seteaza proprietatile functiei zoom 
Analyze: Analizeaza harta afisata
Add map elements: Adauga elementele grafice ale hartii (scara, legenda, titlu)
Save display to graphic file: Salveaza spatiul de lucru in format imagine
Print display: Imprima spatiul de lucru



Fereastra de manipulare

File: optiuni pentru lucrul cu fisierele
Config: configureaza zona de lucru
Raster: manipuleaza datele rester
Vector: manipuleaza datele vectoriale
Imagery: manipuleaza datele tip imagine
Volume: folosit pentru calcule volumetrice
Databese: manipuleaza bazele de date
Help: ajutor

Bara de meniuri



Fereastra de manipulare

Start new display: deschide o noua fereastra de vizualizare
Load map layers: incarca straturile
Open existing workspace file: deschide un mediu de lucru existent
Save current existing workspace to file: salveaza mediul de lucru curent
Add raster map layer: adauga un strat raster
Add various raster-based map layers: adauga strat raster sub forma de grup
Add vector map layer: adauga un strat vectorial
Add various vector-based map layers: adauga strat vectorial sub foma de grup
Add command layer: adauga un strat tip comanda
Add layer group: adauga un grup de straturi
Add grid or vector labels overlay: adauga gridul matematic sau etichete
Delete selected layer: starge stratul selectat
Show attribute table: vizualizeaza tabelul de atribute al stratului selectat

Bara de butoane



Manipularea datelor in GRASS

Efectuam comada: File > Import raster data > Bulk import of raster data 

Importul datelor raster



Manipularea datelor in GRASS

1. Selectam tipul de fisier: Arc/Info ASCII Grid
2. Selectam locatia: home/user/data/GRASS/dem25wgs.asc
3. Apasam butonul: Import 

Importul datelor raster

In fereastra GIS Layer Manager, la optiunea
Command output, va apare urmatorul mesaj:



Manipularea datelor in GRASS

Accesam: Add raster map layer

Importul datelor raster

Selectam: dem25wgs@PERMANENT
In fereastra Raster map to be displayed 

Apasam: Apply si OK



Manipularea datelor in GRASS

Pentru vizualizarea stratului: Click dreapta de mouse si din meniul contextual alegem

Importul datelor raster

Zoom to selected map(s)



Manipularea datelor in GRASS

In optiunea Command output vor apare datele analitice ale modelului importat

Importul datelor raster



Manipularea datelor in GRASS

Interogarea datelor raster
Optiuni pentru manipulare:



Manipularea datelor in GRASS

Interogarea datelor raster

Pentru selectarea zonei: Click dreapta de mouse si din meniul contextual alegem

Set computational region
from selected map(s)



Manipularea datelor in GRASS

Interogarea datelor raster

Pentru selectarea zonei: Click dreapta de mouse si din meniul contextual alegem

Set computational region
from selected map(s)



Manipularea datelor in GRASS

Interogarea datelor raster

Raster > Terrain analysis > Shaded relief



Manipularea datelor in GRASS

Interogarea datelor raster
La Imput elevation map alegem: dem25wgs@PERMANENT si apasam Run apoi Close



Manipularea datelor in GRASS

Interogarea datelor raster 
Accesam Add raster map layer, la Raster map to be displayed alegem: 
dem25wgs.shade@PERMANENT, apasam Apply si Close



Manipularea datelor in GRASS

Interogarea datelor raster - Realizarea 3D
In fereastra GRASS GIS Layer Manager, schimbam ordinea de afisare a stratelor astfel:

1.dem25wgs@PERMANENT  
2.dem25wgs.shade@PERMANENT

Click dreapta pe 
dem25wgs@PERMANENT

si alegem
Change opacity level



Manipularea datelor in GRASS

Interogarea datelor raster 

In fereastra Set opacity, selectam opacitatea la 50 unitati



Manipularea datelor in GRASS

Interogarea datelor raster 

Rezultatul final



Manipularea datelor in GRASS

Interogarea datelor raster - Vizualizare 3D

In fereastra GRASS GIS Layer Manager efectuam: File > NVIZ



Manipularea datelor in GRASS

Interogarea datelor raster - Vizualizare 3D

Alegem la Name of raster(s) for Elevations: dem25wgs@PERMANENT, iar la Name of 
raster map(s) for Color: dem25wgs@PERMANENT si rulam comanda.



Manipularea datelor in GRASS

Interogarea datelor raster - Vizualizare 3D
Rezultatul final:



Manipularea datelor in GRASS

Interogarea datelor raster - Vizualizare 3D

Drapare harta topografica:
1. Importare harta in spatiul de lucru
2. Deschiderea ferestrei NVIZ
3. Alegem la Name of raster(s) for Elevations: dem25wgs@PERMANENT, iar la
Name of raster map(s) for Color: topo@PERMANENT si rulam comanda. 



Manipularea datelor in GRASS

Interogarea datelor raster - Vizualizare 3D
Rezultatul final:



Manipularea datelor in GRASS

Interogarea datelor raster - Vizualizare 3D

Schimbarea proprietatilor de vizualizare

Se face cu optiunea Lighting Panel : Apparence > Lighting

Light source position: directia de iluminare

Light color: modifica nuantele de culoare

Light intensity: modifica intensitatea luminii



Manipularea datelor in GRASS

Interogarea datelor raster - Vizualizare 3D

Schimbarea proprietatilor de vizualizare



Manipularea datelor in GRASS

Interogarea datelor raster - Vizualizare 3D

Se utilizeaza optiunea Surface panel: Vizualize > Raster Surface

Intersectarea suprafetei cu un plan orizontal

Current: stratul aspura caruia se fac modificari

Surface attributes: modificarea atributelor suprafetei

Resolution: cresterea/scaderea rezolutiei

DRAW CURRENT: se aplica dupa fiecare modificare



Manipularea datelor in GRASS

Interogarea datelor raster - Vizualizare 3D

Introducem planul de sectionare: New > New Constant

Intersectarea suprafetei cu un plan orizontal

New Constant:Adauga proprietatea Z planului
Constant: se introduce valoarea Z

Dupa introducerea valorii, aceasta apare la optiunea:
Curr.value (in cazul nostru 175)



Manipularea datelor in GRASS

Interogarea datelor raster - Vizualizare 3D

Rezultatul final:

Intersectarea suprafetei cu un plan orizontal



Manipularea datelor in GRASS

Interogarea datelor raster - Vizualizare 3D

Schimbarea transparentei stratului creat: Surface attributes... > transparency

Intersectarea suprafetei cu un plan orizontal

New Constant:Adauga transparenta planului
Constant: se introduce valoarea transparentei

Dupa introducerea valorii, aceasta apare la optiunea:
Curr.value (in cazul nostru 165)



Manipularea datelor in GRASS

Interogarea datelor raster - Vizualizare 3D

Rezultatul final:

Intersectarea suprafetei cu un plan orizontal



Manipularea datelor in GRASS

Interogarea datelor raster - profile

In fereastra de vizualizare alegem: Analyze > Profile surface map

Selectam datele



Manipularea datelor in GRASS

Interogarea datelor raster - profile
In Profile Analysis alegem: Draw transect in map display window profile

Trasam linia de profil



Manipularea datelor in GRASS

Interogarea datelor raster - profile

In fereastra Profile Analysis alegem: Draw/re-draw profile



Manipularea datelor in GRASS

1. Selectam tipul de fisier: ESRI Shapefile
2. Selectam locatia: home/user/data/GRASS/localit_plg/localit_plg.shp
3. Apasam butonul: Import 

Importul datelor vectoriale

In fereastra GIS Layer Manager, la optiunea
Command output, va apare urmatorul mesaj:



Manipularea datelor in GRASS

Accesam: Add vector map layer

Importul datelor vectoriale

Selectam: dem25wgs@PERMANENT
In fereastra Raster map to be displayed 

Apasam: Apply si OK



Manipularea datelor in GRASS

Rezultatul final:

Importul datelor vectoriale



Manipularea datelor in GRASS

Optiuni pentru
manipulare:

Importul datelor vectoriale



Manipularea datelor in GRASS

Vizualizare 3D – alegerea datelor de intrare:

Importul datelor vectoriale

Selectarea datelor raster: Selectarea datelor vectoriale:



Manipularea datelor in GRASS

Vizualizare 3D – rezultatul final:
Importul datelor vectoriale



Manipularea datelor in GRASS

Importul imaginilor satelitare

Alegem: Import raster data > Bulk import of raster data

Date: /GRASS/landsat_etm+

Formatul ales:
National Imagery 
Transmission Format

Importam pe rand benzile spectrale:
1, 2, 3, 4, 5 si 7:

L71183029_02920070727_B10.TIF
L71183029_02920070727_B20.TIF
L71183029_02920070727_B30.TIF
L71183029_02920070727_B40.TIF
L71183029_02920070727_B50.TIF
L71183029_02920070727_B70.TIF



Manipularea datelor in GRASS

Importul imaginilor satelitare

Importul va crea pentru fiecare banda 3 imagini:
L71183029_02920070727_B10.blue@PERMANENT
L71183029_02920070727_B10.green@PERMANENT
L71183029_02920070727_B10.red@PERMANENT



Manipularea datelor in GRASS

Importul imaginilor satelitare
Executam comanda: Raster > Manage colors > Create RGB 



Manipularea datelor in GRASS

Alegem pentru fiecare strat banda dorit apasand butonul corespunzator. 
Exemplu:

Red: L71183029_02920070727_B40.red
Green: L71183029_02920070727_B30.green

Blue:L71183029_02920070727_B20.blue

Importul imaginilor satelitare

Completam numele imaginii de iesire:
> rgb_432

Adaugam rasterul creat
> Add raster map layer

Vizualizam rasterul



Manipularea datelor in GRASS

Combinatii de benzi:
Interogarea imaginilor satelitare

Combinatia 
spectrala Caracteristici

4,3,2

Vegetatie în 
nuanţe de rosu, 

zone urbane sunt 
albastru cyan, 

solurile cu nuante 
de maro



Manipularea datelor in GRASS

Combinatii de benzi:
Interogarea imaginilor satelitare

Combinatia 
spectrala Caracteristici

3,2,1

Vegetatie în 
nuante de verde, 
zone urbane sunt 

albastru cyan, 



Manipularea datelor in GRASS

Combinatii de benzi:
Interogarea imaginilor satelitare

Combinatia 
spectrala Caracteristici

7,4,2

Vegetatie în 
nuante de verde, 
aprins. Incendiile  

apar in rosu. 



Manipularea datelor in GRASS

Combinatii de benzi:
Interogarea imaginilor satelitare

Combinatia 
spectrala Caracteristici

4,5,1

Vegetatie în 
nuante de maro. 

Apa apare in 
albastru. 



Manipularea datelor in GRASS

Combinatia de benzi se poate vizualiza si in dormat 3D cu NVIZ
Elevation raster: dem25wgs
Color raster: rgb_432 

Interogarea imaginilor satelitare



Manipularea datelor in GRASS

Explorarea 3D a realitatii geografice

Importare ortofotoplan: 
File > Import raster data > Bulk import of raster data



Manipularea datelor in GRASS

Vizualizare ortofotoplan:  Add raster map layer

Explorarea 3D a realitatii geografice



Manipularea datelor in GRASS

Importare cladiri: 
File > Import vector data > Bulk import of vector data

Explorarea 3D a realitatii geografice



Manipularea datelor in GRASS

Vizualizare cladiri:  Add vector map layer

Explorarea 3D a realitatii geografice



Manipularea datelor in GRASS

Rezultat:

Explorarea 3D a realitatii geografice



Manipularea datelor in GRASS

Realizarea cladirilor in 3D:
> Vector

> Develop vector map

> Extrude 3D vector map

Explorarea 3D a realitatii geografice



Manipularea datelor in GRASS

In fereastra v.extrude completam
cerintele obligatorii:

Name on imput vector map:
> cladiri@PERMANENT

Name of resulting 3D vactor map
> cladiri3d

Explorarea 3D a realitatii geografice



Manipularea datelor in GRASS

... precum si cerintele obtionale:

Bifam:
> Trace elevation

Elevation raster of height extraction
> dem25wgs@PERMANENT

Fixed height for 3D vector objects:
> 5

Bifam:
> Add created map into layer tree

Rulam comanda

Explorarea 3D a realitatii geografice



Manipularea datelor in GRASS

In fereastra GRASS GIS Layer Manager avem elementele: 

Explorarea 3D a realitatii geografice

Display1:
> cladiri3d@PERMANENT

> orto_2m@PERMANENT

> dem25wgs@PERMANENT



Manipularea datelor in GRASS

Completam datele raster:

Name of raster map(s) for Elevation:
> dem25wgs@PERMANENT

Nameof raster map for Color:
> orto_2m@PERMANENT

Explorarea 3D a realitatii geografice

Vizualizarea 3D: File > NVIZ



Manipularea datelor in GRASS

Completam datele Vector:

Name of vector overlay map(s):
> cladiri3d@PERMANENT
> drumuri@PERMANENT
> rauri@PERMANENT

Explorarea 3D a realitatii geografice

Vizualizarea 3D: File > NVIZ

Rulam comanda



Manipularea datelor in GRASS

Explorarea 3D a realitatii geografice
Fereastra NVIZ are urmatorul aspect: 



Manipularea datelor in GRASS

Explorarea 3D a realitatii geografice

Modificarea proprietatilor cladirilor se face cu optiunea Vector Lines Panel:
Executam in fereastra NVIZ: Fisualize > Vector Line/3D Polygons

Line width: dimensiunea liniilor
Color: culoarea cladirilor



Manipularea datelor in GRASS

Pregatirea de imprimare/exportare

Pentru scara hartii
Executam in fereastra de vizualizare: 
Add map elements > Add scale bar and north arrow



Manipularea datelor in GRASS

Pregatirea de imprimare/exportare

Pentru legenda
Executam in fereastra de vizualizare: 
Add map elements > Add legend

Cu completare la 
List of discrete
A valorilor:
450, 350, 250, 150

Cu completare la 
List of discrete



Manipularea datelor in GRASS

Pregatirea de imprimare/exportare

Pentru Titlu
Executam in fereastra de vizualizare: 
Add map elements > Add text layer

Se seteaza si proprietatile fontului: Set fornt



Manipularea datelor in GRASS

Pregatirea de imprimare/exportare
Rezultatul final pentru salvare imagine: Save display to graphic file



V A    M U L T U M I M !
contact@corneltudose.ro

ionut@ovejanu.eu

http://www.geo -spatial.org 
http://www.freegis.ro


